tix/test/watch.test.nix
2024-01-03 11:17:47 +00:00

21 lines
375 B
Nix

{
describe,
it,
...
}: let
mockpkgs = {
writeShellScriptBin = name: content: content;
inotify-tools = "inotify-tools";
};
watch = import ../tix/watch.nix mockpkgs;
in [
(describe "watch" [
(it "contains the command" {
actual = builtins.match ".*(run me).*" (watch {
cmd = "run me";
});
expected = ["run me"];
})
])
]