tix/test/test.test.nix
2024-12-08 21:27:18 +00:00

23 lines
449 B
Nix

{
describe,
it,
...
}: let
test = import ../tix/test.nix;
in [
(describe "the test function" [
(it "get's test results" {
expected."an example".succeeds.success = true;
actual = test ./example.test.nix;
})
(it "fails to build non test" {
actual = test ./bad/string.nix;
throws = true;
})
(it "tests suite that is not a file" {
actual = test ({...}: []);
expected = {};
})
])
]