nixite/flake.nix

47 lines
1.1 KiB
Nix

{
description = "A site in nix?";
inputs = {tix.url = "git+https://git.tristans.cloud/tristan/tix";};
outputs = {
self,
nixpkgs,
tix,
}: let
system = "x86_64-linux";
pkgs = import nixpkgs {inherit system;};
nixite = import ./nixite/. {inherit pkgs;};
my-site = import ./testing/my-site.nix {inherit nixite;};
in
nixite
// {
formatter.${system} = pkgs.alejandra;
packages.${system} = {
raw = nixite.mkSite my-site;
default = nixite.serve my-site {};
dev = tix.watch {
setup = ''
nix build .#raw
${pkgs.caddy}/bin/caddy file-server --root result &
'';
cmd = ''
nix build .#raw
'';
};
inherit (tix.packages.${system}) watch watchpipe results;
test = tix.run [
# ./testing/md.test.nix
./testing/html.test.nix
./testing/elems.test.nix
./testing/builder.test.nix
./testing/site.test.nix
./testing/style.test.nix
];
};
};
}